Payment processing impacted by Cloudflare outage

Incident Report for Action Property Management

Resolved

Thank you for your patience while we awaited resolution from our payment provider, Payabli, and their downstream providers. We have been informed that the incident has been resolved and all downstream processes have been restored.

Please note that any Resident Portal transactions that may have declined during the outage will need to be reattempted. Thank you again for your patience and understanding.
Posted Nov 18, 2025 - 11:27 PST

Identified

We’ve been alerted to a critical disruption in payment processing due to a widespread Cloudflare outage. Payabli, our payment provider, relies on Cloudflare infrastructure, and this outage is currently affecting payment operations across our Resident Portal.
Impacted Features:
Resident Portal access to Payment Options, One-time Payments, and Autopayment setup
We are actively monitoring the situation and will provide updates as soon as Payabli confirms resolution.
Posted Nov 18, 2025 - 07:35 PST
This incident affected: SnapHOA (Mobile App, Resident/Board Portal).