Resident Portal Password Reset Emails Issue

Incident Report for Action Property Management

Resolved

We’re happy to confirm that the issue has now been resolved. If you encounter any further issues, please Contact Support and we will be more than happy to assist you.

As always, we thank you for your patience!
Posted Oct 24, 2025 - 11:26 PDT

Investigating

We are currently aware of an issue affecting residents' ability to reset their Resident Portal passwords using the “Forgot Password” option on the Resident Portal Website, as well as team members’ ability to send these Resident Portal password reset emails from SnapHOA – Management.

Our team is actively investigating the issue and working toward a resolution. We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Oct 24, 2025 - 11:19 PDT
This incident affected: SnapHOA (Management App, Resident/Board Portal).