Intermittent Email Service

Incident Report for Action Property Management

Resolved

Microsoft has confirmed that the previously reported issue affecting their email service has been resolved.

Email services have stabilized, and we should no longer experience outages or delays when sending or receiving messages. If you do experience any issues with sending or receiving email, please go to https://linktree.actionlife.com and use the Contact Support link for assistance.

As always, thank you for your patience.
Posted Jan 26, 2026 - 09:39 PST

Identified

We are aware of an issue affecting Microsoft’s email service, which our company relies on. This issue may cause intermittent outages or delays in sending and receiving emails. Microsoft is actively working to resolve the problem, and we will provide an update once services have stabilized.
Posted Jan 22, 2026 - 13:00 PST
This incident affected: Exchange 365 (Email).