Resident Portal: One-Time Payment Error

Incident Report for Action Property Management

Resolved

We are happy to inform you that the issue affecting our residents’ ability to make one-time payments in the Resident Portal (both via the website and the mobile app) has been resolved.

If any residents experience further issues processing a payment, please use the Contact Support link located at https://linktree.actionlife.com to report it.

As always, thank you for your patience and understanding.
Posted Nov 24, 2025 - 14:10 PST

Investigating

It has come to our attention that one-time payments made in the Resident Portal (both via the website and mobile app) are currently unable to process at this time. Our team is currently investigating the issue and is working towards a resolution. Please be on the lookout for future updates.

Thank you for your patience.
Posted Nov 24, 2025 - 09:40 PST
This incident affected: SnapHOA (Mobile App, Resident/Board Portal).