Delays with Accounting Information in CINC Systems

Incident Report for Action Property Management

Monitoring

Our team will continue to actively monitor systems as CINC works on a resolution over the next few weeks. You may notice occasional or intermittent delays during this time. We will continue to share any provided updates. If you encounter issues beyond slow performance, please contact the Technology Support Department for assistance.

Thank you for your continued patience.
Posted Dec 04, 2025 - 10:54 PST

Investigating

We are currently experiencing delayed response times with our backend accounting platform, CINC Systems. As a result, users may encounter extended wait times or intermittent errors when accessing information through the SnapHOA system. Our team is actively working with our partners at CINC Systems to resolve the issue as quickly as possible. We appreciate your patience during this time. If you encounter issues beyond slow performance or access errors, please contact the Technology Support Department for further assistance.

Thank you for your attention to this matter.
Posted Dec 02, 2025 - 09:28 PST
This incident affects: SnapHOA (Management App, Resident/Board Portal).